BETA

17th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [17/06/18 07:23 PM] with 'Major Outage'

Issue has been resolved at [17/06/18 07:24 PM]