BETA

17th June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [17/06/18 03:07 PM] with 'Partial Outage'

Issue has been resolved at [17/06/18 03:09 PM]