BETA Singapore cluster       Mumbai cluster

30th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [30/04/19 02:44 AM] with 'Partial Outage'

Issue has been resolved at [30/04/19 02:46 AM]