BETA

17th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [17/06/18 12:24 PM] with 'Partial Outage'

Issue has been resolved at [17/06/18 12:25 PM]