BETA

16th June 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [16/06/18 05:04 PM] with 'Partial Outage'

Issue has been resolved at [16/06/18 05:05 PM]