BETA

16th June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [16/06/18 02:26 PM] with 'Partial Outage'

Issue has been resolved at [16/06/18 02:30 PM]