BETA

16th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/06/18 01:45 PM] with 'Major Outage'

Issue has been resolved at [16/06/18 01:47 PM]