BETA

30th April 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [30/04/19 02:07 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/04/19 02:14 AM]