BETA

5th April 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [05/04/17 05:52 PM] with 'Partial Outage'

Issue has been resolved at [05/04/17 05:54 PM]