BETA

16th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [16/06/18 03:04 AM] with 'Major Outage'

Issue has been resolved at [16/06/18 03:05 AM]