BETA

15th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [15/06/18 08:49 PM] with 'Major Outage'

Issue has been resolved at [15/06/18 08:50 PM]