BETA

14th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/06/18 09:23 PM] with 'Major Outage'

Issue has been resolved at [14/06/18 09:24 PM]