BETA

14th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/06/18 03:40 PM] with 'Major Outage'

Issue has been resolved at [14/06/18 03:41 PM]