BETA

13th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [13/06/18 08:09 PM] with 'Major Outage'

Issue has been resolved at [13/06/18 08:13 PM]