BETA

13th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/06/18 07:37 AM] with 'Major Outage'

Issue has been resolved at [13/06/18 07:39 AM]