BETA

12th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/06/18 11:50 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/06/18 12:44 AM]