BETA

12th June 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/06/18 11:21 PM] with 'Partial Outage'

Issue has been resolved at [12/06/18 11:45 PM]