BETA

12th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/06/18 11:01 PM] with 'Major Outage'

Issue has been resolved at [12/06/18 11:18 PM]