BETA

12th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/06/18 10:27 PM] with 'Partial Outage'

Issue has been resolved at [13/06/18 01:14 AM]