BETA

12th June 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/06/18 10:18 PM] with 'Major Outage'

Issue has been resolved at [12/06/18 10:21 PM]