BETA

12th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/06/18 12:25 PM] with 'Major Outage'

Issue has been resolved at [12/06/18 12:37 PM]