BETA

12th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/06/18 12:24 PM] with 'Major Outage'

Issue has been resolved at [12/06/18 12:32 PM]