BETA

12th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/06/18 12:13 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [12/06/18 12:27 PM]