BETA

12th June 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/06/18 10:49 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [12/06/18 11:21 AM]