BETA

12th June 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [12/06/18 10:19 AM] with 'Major Outage'

Issue has been resolved at [12/06/18 10:56 AM]