BETA

12th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/06/18 09:58 AM] with 'Partial Outage'

Issue has been resolved at [12/06/18 10:03 AM]