BETA

12th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/06/18 09:24 AM] with 'Major Outage'

Issue has been resolved at [12/06/18 09:26 AM]