BETA

12th June 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/06/18 08:41 AM] with 'Major Outage'

Issue has been resolved at [12/06/18 08:49 AM]