BETA

12th June 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/06/18 08:34 AM] with 'Major Outage'

Issue has been resolved at [12/06/18 09:04 AM]