BETA

10th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [10/06/18 09:15 PM] with 'Major Outage'

Issue has been resolved at [10/06/18 09:16 PM]