BETA

10th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [10/06/18 04:13 AM] with 'Partial Outage'

Issue has been resolved at [10/06/18 04:14 AM]