BETA

9th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [09/06/18 08:59 PM] with 'Major Outage'

Issue has been resolved at [09/06/18 09:00 PM]