BETA

8th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [08/06/18 09:41 PM] with 'Major Outage'

Issue has been resolved at [08/06/18 09:42 PM]