BETA

8th June 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [08/06/18 06:05 PM] with 'Major Outage'

Issue has been resolved at [08/06/18 06:07 PM]