BETA

7th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [07/06/18 08:58 PM] with 'Major Outage'

Issue has been resolved at [07/06/18 09:00 PM]