BETA

7th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [07/06/18 06:29 PM] with 'Major Outage'

Issue has been resolved at [07/06/18 06:31 PM]