BETA

7th June 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [07/06/18 11:46 AM] with 'Major Outage'

Issue has been resolved at [07/06/18 11:47 AM]