BETA

6th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [06/06/18 09:20 PM] with 'Major Outage'

Issue has been resolved at [06/06/18 09:22 PM]