BETA

6th June 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [06/06/18 10:56 AM] with 'Major Outage'

Issue has been resolved at [06/06/18 11:01 AM]