BETA

6th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [06/06/18 12:38 AM] with 'Partial Outage'

Issue has been resolved at [06/06/18 12:39 AM]