BETA

5th June 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/06/18 07:29 PM] with 'Partial Outage'

Issue has been resolved at [05/06/18 07:31 PM]