BETA Singapore cluster       Mumbai cluster

29th April 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/04/19 11:33 PM] with 'Partial Outage'

Issue has been resolved at [29/04/19 11:46 PM]