BETA

5th June 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [05/06/18 06:14 PM] with 'Partial Outage'

Issue has been resolved at [05/06/18 06:23 PM]