BETA

5th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/06/18 06:08 PM] with 'Major Outage'

Issue has been resolved at [05/06/18 06:17 PM]