BETA

5th June 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [05/06/18 06:05 PM] with 'Major Outage'

Issue has been resolved at [05/06/18 06:09 PM]