BETA

5th June 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [05/06/18 05:17 PM] with 'Major Outage'

Issue has been resolved at [05/06/18 05:28 PM]