BETA

4th June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [04/06/18 10:36 PM] with 'Major Outage'

Issue has been resolved at [04/06/18 10:52 PM]