BETA

4th June 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [04/06/18 10:34 PM] with 'Major Outage'

Issue has been resolved at [04/06/18 10:51 PM]