BETA

4th June 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [04/06/18 05:45 AM] with 'Partial Outage'

Issue has been resolved at [04/06/18 07:19 AM]