BETA

4th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [04/06/18 05:37 AM] with 'Partial Outage'

Issue has been resolved at [04/06/18 05:39 AM]